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Introducing CentreWare Printer Drivers
for Microsoft Windows

Printer drivers are software programs that enable a printer to work with an operating 
system. The driver interfaces with the printer and operating system software by 
sending commands which perform printing tasks. This documentation discusses the 
CentreWare Printer Drivers for the Document Centre family of products that run in 
Microsoft Windows environments.

Integrated fax capabilities vary with each Document Centre Model. Not all Xerox 
printers support both network printing and LAN fax submitted from the desktop. 
Check your product specific literature for more details. Other network fax options can 
be configured with different models, using third-party software applications.

What�s in this chapter:
! What�s New in this Release? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . vi

! Printer Driver Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . vi

! Document Centre PPD Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ix

! CentreWare Printer Driver Applications. . . . . . . . . . . . . . . . . . . . . . . . . . . . x

! Printer Driver Documentation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xi

! CentreWare Printer Driver Support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . xii

NOTE: For CentreWare support of new releases of Microsoft Windows 
products, visit www.xerox.com on the web for more information.
v
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What�s New in this Release?
The CentreWare 5.40 release of the Document Centre printer drivers, supports the 
following new features and hardware:

! Document Centre models 555/545/535

! Finisher options

! Bi-Directional printer drivers

! 98 USB printer drivers

! PCL 6 (XL) printer drivers

Printer Driver Overview
A printer driver enables documents created with specialized software applications 
(word processing, spreadsheets, graphics) to be compatible with a specific printer. 
Each type of printer may require unique commands to print correctly and to enable 
special features. For these reasons, different types of printers require their own printer 
drivers to operate correctly. 

CentreWare printer drivers enable printing from a workstation to a Document Centre 
in a network environment. The CentreWare drivers contain a variety of feature 
options which enable you to customize your print jobs. 

NOTE: Print and fax drivers for Document Centres previous to the 500 
model series are not included on the CentreWare Print and Fax Drivers 
CD, but are available on the Xerox Web site. See Internet Support on 
page xii for the Xerox Web site link.



CentreWare Printer Drivers
There are two kinds of CentreWare printer drivers:

! Enhanced or custom (folders containing  _enhanced extension)

! Standard or mini (folders containing  _standard extension)

The CentreWare printer drivers are available in PostScript 3, PCL 5e, and PCL 6 (XL) 
printing formats.

Enhanced Driver
Enhanced printer drivers are drivers whose options are displayed on tabs within the 
driver. These printer drivers are designed specifically for Xerox products, and they 
offer some advanced features that are not available in the standard printer drivers. 
CentreWare enhanced drivers are available for Windows 95/98/Me/NT/2000/XP 
workstations.

Enhanced Printer Driver
Printer Driver Overview vii
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Standard Driver
Standard printer drivers conform to the Microsoft Windows driver standards. The 
options are displayed in tree form, which is generic across many software products. 
These CentreWare printer drivers are available for Windows NT 4.0, Windows 2000, 
and XP workstations.

PostScript
PostScript gives you greater ability to scale and manipulate images; it offers more 
precision with high-end graphics. PostScript also provides you with different types of 
error-handling and font substitution options. 

PCL
PCL (Printer Command Language) generally has fewer advanced features than 
PostScript. However, using PCL enables you to process most jobs faster. 

Standard Printer Driver



Document Centre PPD Files
A PostScript Printer Description file (PPD) is a readable text file that provides a 
uniform approach to specifying special features for printer drivers that interpret 
PostScript. 

Xerox provides PostScript 3 PPDs for all of the Document Centre models. They are 
automatically installed simultaneously with the printer driver.

Two different PPD files are provided for the Document Centres:

! Generic PPD (PS/3) for standard DC 555/545/535

! DocuTech PPD (PS/3) for DC 555/545/535

DocuTech 135 Print Emulation PPD
For Document Centres 555/545/535, a PPD is provided that enables DocuTech 135 
print emulation. This PPD automatically adjusts various print quality and layout 
settings, such as halftone screen (85 dpi at 45 degrees), margins (none), and resolution 
(600x600x1), to provide print quality and page layout that is similar to a Xerox 
DocuTech 135 Networked and Production Publisher system. 
Document Centre PPD Files ix
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CentreWare Printer Driver Applications
The following applications are included with the CentreWare printer drivers:

! TIFF Submission Tool 

! Font Management Utility

! Port Monitor

TIFF Submission Tool
The TIFF Submission Tool enables users to submit TIFF (Tagged Image File Format) 
files directly to a Document Centre for printing. TIFF files print faster when they are 
sent to the Document Centre in this format. 

See Installing and Using the TIFF Submission Tool on page 6-1 for more information.

Font Management Utility
The Font Management Utility is a tool used for managing fonts and printer lists. 
Using the utility, fonts may be viewed, printed, downloaded to printers, or exported to 
a file. Printers can be added or deleted from a printer list, which is used for adding and 
deleting fonts from one or multiple printers. 

See Installing and Using the Font Management Utility on page 4-1 for more 
information.

TCP/IP Port Monitor 
The Xerox TCP/IP Port Monitor is used with Bi-Directional CentreWare printer 
drivers and for printing in Windows using LPR or Port 9100. 

See Installing and Using the Xerox TCP/IP Port Monitor on page 5-1 for more 
information.

NOTE: A TIFF interpreter on your Document Centre is required for this 
tool.



Printer Driver Documentation
CentreWare Print and Fax Drivers Guide for Windows
This guide is intended for administrators who install and configure CentreWare 
Printer drivers. The guide also contains information, focused for general users, on 
printing and faxing options available with the drivers. 

The CentreWare Print and Fax Drivers Guide is available on the CentreWare Print and 
Fax Drivers CD in electronic (PDF) format. 

An English version of the Adobe Acrobat Reader is provided on the CentreWare Print 
and Fax Drivers CD. This works on most workstations running a non-English version 
of Windows, except Windows 2000. You can download a reader for other languages 
from Adobe at www.adobe.com/products/acrobat/readstep2.html.

Help
Help is available for the CentreWare Printer Drivers through Help buttons and What�s 
This? context sensitive help. Included are feature descriptions, step-by-step 
procedures, Document Centre information, problem solving information, and support 
information. 
Printer Driver Documentation xi
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CentreWare Printer Driver Support
Internet Support
Visit Xerox on the Internet at www.Xerox.com. The Web site contains Document 
Centre product information, product overviews and support, and the latest 
information about CentreWare Printer Driver releases. 

DC Tips
Additional tips and technical information for printer drivers are available at the Xerox 
Web site by locating your product and accessing the DC Tips link. Document Centre 
Family Tips (DC Tips) cover specific topics concerning Document Centre operation 
and configuration which may require special procedures or application notes.   

Telephone Support
For additional assistance, you may contact the Xerox Welcome Center by telephone 
to speak with a Product Support Analyst. Locate your Document Centre serial 
number, and record it in the space below before you make your call.

The Xerox Welcome Center telephone numbers are listed in the following table. If the 
Welcome Center telephone number for your country is not listed, it will be provided 
to you when your Document Centre is installed. For future reference, please record 
the telephone number in the space provided below. 

Document Centre Serial Number:

Welcome Center Telephone Numbers:

UNITED STATES 800-821-2797

CANADA 800-939-3769 (800-93-XEROX)

http://www.xerox.com
http://www.xerox.com/DocumentCentreFamily/Tips


Before Installing
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Before Installing

Reading this background information about printer drivers and the types of 
connections between your workstation and printer will aid your choices during the 
installation process.

What�s in this chapter:
! Installation Options Using the Xerox Printer Installer . . . . . . . . . . . . . . . 1-2

! Point and Print Connection. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-3

! Obtaining CentreWare Print and Fax Drivers  . . . . . . . . . . . . . . . . . . . . . 1-4

! Downloading from the Web . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-5

! Installing from a Server. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-5
1-1



1-2 B
Installation Options Using the Xerox 
Printer Installer

You have the option of using the Xerox Printer Installer or the Windows Add Printer 
Wizard to set up and install your printer drivers. 

By using the Xerox Printer Installer you can install multiple components at the same 
time, such as printer drivers, PPDs, user documentation, and the Port Monitor utility. 

The Xerox Printer Installer leads you through the steps to set up and install the type of 
printer driver and the components you want for your Document Centre. You may 
choose from three types of installation:

! Custom�Users who want to make their own selection of PCL or PostScript 
drivers and components to install, or who want to change the default 
locations of some software components, should choose this option.

! Easy�Most users will find this installation the best choice. This option 
installs a PostScript printer driver and PPDs for your operating environment, 
the Port Monitor utility (when you choose a network (peer-to-peer) 
connection for your printer), User Guide, and Readme.

! Minimal�Users who only want to install a PostScript printer driver for their 
operating environment should choose this type of installation.

When you are installing from the CentreWare Print & Fax Drivers CD, the AutoRun 
program provides two Xerox Printer Installers: Install Your Windows 9x/Me Xerox 
Printer and Install Your Windows NT/2000/XP Xerox Printer. 

The Windows Add Printer Wizard leads you through a process to set up and install 
your printer and printer driver. The installation procedures for each environment 
typically follow the standard installation process for each operating system.
efore Installing



Point and Print Connection 
Microsoft Point and Print enables Windows clients to connect to a remote printer 
without performing an installation procedure on each client workstation after the 
printer installation has been performed on the server. The configuration information 
and files are downloaded from the server to the client automatically.

To perform Point and Print:

1 At the client workstation, access the desired network Document Centre through 
Network Neighborhood (Win 95/98/NT) or My Network Places (Me/Win 
2000/XP). Browse to your printer.

2 Double-click the Document Centre icon. At the prompt, select to install the 
printer driver. The Add Printer Wizard opens.

�Or�

Click the Document Centre icon. Drag and drop the printer icon on the Printers 
folder. The Add Printer Wizard opens. 

3 Follow the Add Printer Wizard instructions.

The appropriate files for the selected Document Centre download to the client 
workstation.

NOTE: This procedure assumes that a Document Centre on a network server has 
been installed/upgraded with the appropriate CentreWare printer driver prior to 
performing Point and Print.
Point and Print Connection 1-3



1-4 B
Obtaining CentreWare Print and Fax Drivers
The following table shows the Document Centre models supported in this release of 
CentreWare and the printer drivers that are available for Windows 95/98/Me/NT/
Windows 2000 and XP environments. 

CentreWare Print and Fax Drivers CD
The installation files for the Document Centre 555/545/535 PostScript and PCL 5e 
printer drivers are available on the Xerox CentreWare 5.40 Print and Fax Drivers CD.

For updates and additional information check the Xerox Web site at www.Xerox.com. 

CentreWare Printer 
Drivers

(Windows 95/98/Me/NT/
2000/XP)

Document Centre (DC)
Models

Location

PostScript 3 DC 555/545/535 CD/Web

PCL 5e DC 555/545/535 CD/Web

PCL 6 (XL) DC 555/545/535 Web

Table 1-1:  CentreWare Printer Drivers for Xerox Document Centres
efore Installing



Downloading from the Web
Document Centre printer drivers can be downloaded from the Xerox Web site at 
www.Xerox.com. The installation files for all Document Centre models are available 
from the Web site. 

To download printer drivers:

1 Access the Xerox Web site and click the Drivers link. 

2 Select your Document Centre model from the Product drop-down list.

3 Select the desired Operating System (Windows) and Language for the printer 
driver.

4 Click Go.

5 After the printer driver is downloaded, follow the instructions for installing or 
upgrading which are presented in this chapter. 

Installing from a Server
Your site may have a directory on a server that contains print and fax drivers. Check 
with your Network or System Administrator for details and specific instructions that 
pertain to your network environment.
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Installing Windows Printer Drivers

The CentreWare printer drivers support the special features and functions of Xerox 
Document Centres, enabling fast, efficient printing from your desktop. Installation 
instructions for all current Windows environments are provided in this chapter.

What�s in this chapter:
! Workstation Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-2

! Network Print Configurations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-2

! Installing Printer Drivers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-3

! Configuring Printer Drivers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-9

! Bi-Directional Printer Drivers  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-11

! Windows Printer Driver Table  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-12

! Uninstalling the Xerox Printer Installer . . . . . . . . . . . . . . . . . . . . . . . . . 2-13

! Uninstalling Windows Printer Drivers . . . . . . . . . . . . . . . . . . . . . . . . . . 2-14
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Workstation Requirements
The minimum hardware requirements for the CentreWare printer drivers vary based 
on the specific printer driver you are installing. At the most, you will need 2.5 MB of 
available hard disk space for any of the CentreWare Windows printer drivers.

Network Print Configurations 
Client/Server
In Client/Server environments, a printer driver is installed on a server and shared with 
other servers and workstations on the network. The printer driver is downloaded to 
the workstation from the server. In this network setup, only a Network Administrator 
can maintain the printer defaults and configuration.

Client-Direct-to-Printer 
In Client-Direct-to-Printer environments, a printer driver is installed on a workstation 
that is connected to a printer. The printer driver resides only on the workstation. In 
this network setup, workstation users maintain their own printer defaults and 
configurations, allowing different printer settings for each user.

NOTE: Client/Server First-time Installations: Windows NT 4.0 standard 
printer drivers can be installed and share a print queue in Windows 
2000, but not Windows NT enhanced drivers. Conflicts will occur if you 
share a queue between Windows NT enhanced drivers and Windows 
2000 drivers. Select Custom Setup to choose the appropriate driver.
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Installing Printer Drivers
Use this procedure for installing printer drivers and other components in 9x/Me and 
NT/2000/XP environments. 

Read this information before installing your printer drivers: 
Reading this background information about printer drivers and the types of 
connections between your workstation and printer will aid your choices during the 
installation process. See Before Installing on page 1-1.

To install the Windows printer drivers:

1 If you are installing from the CD, the CentreWare AutoRun program opens when 
you insert the CD. Click Print & Fax Drivers, then either Install Your 
Windows 9x/Me Xerox Printer or Install your Windows NT/2000/XP Xerox 
Printer. The procedures are the same for both.

2 When the Xerox License Agreement dialog appears, click Yes to continue. The 
Setup dialog appears.

NOTE: If you are installing a PCL 6 printer driver, a 98 USB printer driver, 
or a Windows 2000/XP (Enhanced) printer driver, use the Microsoft Add 
Printer Wizard. See the table on page 2-12 for the 98 USB and Windows 
2000/XP printer driver file names and locations on the CentreWare Print 
and Fax Drivers CD. PCL 6 printer drivers are available from the Xerox 
Web site at www.Xerox.com.

NOTE: If you are not installing from the CD, launch the Microsoft Add 
Printer Wizard. First, ensure that the printer driver you want to install is 
available either locally or on a mapped network drive. Complete the 
wizard for your Windows environment.
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3 Click the type of Setup you prefer, then click Next.

a) If you chose Custom, a Choose Destination Location dialog opens. This 
dialog appears only for the first installation. Subsequent component 
installations place files in the destination folder chosen at the first 
installation.

b) Click Next. The Select Components dialog opens. Figure 2-1.

c) Deselect the components you do not want to install. Click Next.

NOTE: Client/Server First-time Installations: Windows NT 4.0 standard 
printer drivers can be installed and share a print queue in Windows 
2000, but not Windows NT enhanced drivers. Conflicts will occur if you 
share a queue between Windows NT enhanced drivers and Windows 
2000 drivers. Select Custom Setup to choose the appropriate driver.

Figure 2-1:  Select Components Dialog
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4 Select your Document Centre printer model. Click Next. The Choose Connection 
Type dialog appears.

5 Choose the type of connection you have to your printer, then click Next.

! If you chose Connected to my network (peer-to-peer), the Discovery 
dialog appears. Figure 2-3 on page 2-6.

! If you chose Shared by a network server (client/server), the Network 
Connection dialog appears. Type the network path or browse to the printer. 
Click Next. The Printer(s) dialog appears. Figure 2-4 on page 2-7.

! If you chose Add Printer Wizard, the Microsoft Add Printer Wizard opens. 
Follow the Add Printer Wizard procedures to finish your installation.

Figure 2-2:  Choose Connection Type Dialog
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The Discovery dialog lists all the printers of your model on your local network. You 
may enter other subnets to add to your list of printers.

6 Do one of the following and then continue with step 7, Printer(s) dialog, Figure 
2-4 on page 2-7.

! Select a printer from the Printer Description list and click Next. The 
Printer(s) dialog appears, Figure 2-4.

�Or�

! If your printer is not in the list, enter an IP address in the Printer IP text box. 
Click Add. The printer is added to the list of available printers. Select the 
printer and click Next. The Printer(s) dialog appears, Figure 2-4.

�Or�

! If your printer is not in the list, enter a Subnet IP address and Subnet mask 
address to discover printers on another local network. The printer is added to 
the list of available printers. Select the printer and click Next. The Printer(s) 
dialog appears, Figure 2-4.

Figure 2-3:  Discovery Dialog
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7 Choose a printer from the Printer(s) dialog, Figure 2-4, list of available choices. 
The name appears in the text box. Do one of the following:

! Click Next to accept the default printer name. The Information Summary 
dialog appears.

�Or�

! Type a new name for your printer in the text box and click Save Change, 
then Next. The Information Summary dialog appears. 

Figure 2-4:  Printer(s) Dialog

NOTE: To make this printer your default printer, select the Default Printer 
check box. The Default Printer check box is selected by default for the 
Easy and Minimal types of installation.
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8 If any information in the Information Summary dialog is incorrect, click Back to 
make a change; otherwise, click Next.  The installation is complete. 

Continue with Configuring Printer Drivers on page 2-9.

NOTE: If the Microsoft Digital Signature dialog appears, click Yes to 
continue.
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Configuring Printer Drivers
After installing the Document Centre printer drivers, you need to configure the 
options that are available for use. Each model can have different installed options, for 
example, a High Capacity Feeder or a Finisher.

  

NOTE: If you are using a (TCP/IP) Bi-Directional printer driver, select the 
Automatically Update Installed Options checkbox to configure your printer 
driver.

Figure 2-5:  Installable Options Configuration
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Windows Printer Drivers Configuration
To configure the CentreWare printer drivers manually:

1 Right-click the icon of the appropriate printer and select Properties.

2 Select the System Configuration tab (enhanced drivers) or the Configuration 
tab (standard drivers). 

3 Select any Installable Options that are available on your Document Centre.

4 Click Apply to save the settings.

5 Click OK to close the printer driver.

Windows Drivers Configuration Using TCP/IP Network
If you have a TCP/IP network, the Windows printer drivers can, as an option, provide 
Bi-directional capabilities. This allows a printer driver to communicate with the 
printer through your network and acquire information from the printer, including its 
current operational status and the status of the paper trays.

To configure the CentreWare printer drivers automatically:

1 Right-click the icon of the appropriate printer and select Properties.

2 Select the Configuration tab (for enhanced drivers) or the System 
Configuration tab (for standard drivers). 

3 Select Automatically Update Installed Options. The options that reside on 
your Document Centre are selected and available for use.

For more information, see Bi-Directional Printer Drivers on page 2-11.
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Bi-Directional Printer Drivers
If you have a TCP/IP network, the Windows 95/98/Me/NT/2000/XP printer drivers 
can as an option provide Bi-Directional capabilities. Bi-Directional communication 
allows a printer driver to communicate with the printer through your network. When 
the printer driver properties are accessed, the printer driver can acquire information 
from the printer, including its current operational status and the status of the paper 
trays. 

After the Windows printer drivers are installed and the TCP/IP Port Monitor is also 
installed, Document Centre installed options and status information are automatically 
updated without having to configure the printer driver manually. 

Configuration
The Configuration Tab (standard drivers) System Configuration Tab (enhanced 
drivers) contains a listing of installed options. When Automatically Update 
Installed Options is selected (default) the options that reside on your Document 
Centre are selected and available for use.

Status
The Status Tab indicates the status of the Document Centre and its paper trays. Printer 
Status shows whether the Document Centre is available. Paper Status indicates the 
type of paper that is loaded in each tray or whether the tray is empty. 

NOTE: The TCP/IP Port Monitor is required for Bi-Directional printer 
drivers. The Xerox Printer Driver Installer automatically installs the TCP/IP 
Port Monitor to your workstation when Connected to my network (peer-
to-peer) is chosen as the type of connection for your printer during the 
installation process. See Installing and Using the Xerox TCP/IP Port 
Monitor on page 5-1 for more information about the Port Monitor.

NOTE: If network communication is temporarily unavailable or is not configured 
properly for the printer, the network, or your workstation, status information does 
not appear.
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Windows Printer Driver Table
To install a Windows 98 USB or a Windows 2000/XP printer driver, use the Microsoft 
Add Printer Wizard.

Table 2-1 lists the folder names that contain the installation files within the 
\Drivers\Windows directory on the CentreWare Print and Fax Drivers CD. 

CentreWare 
Driver

Driver 
Type

Subdirectory Folder Installation 
File Name

 Windows 98
PS \DC555_DC545_DC535 

\PS_5x5_98_USB
PS_555_98
PS_545_98
PS_535_98

usbprint.inf

PCL \DC555_DC545_DC535 
\PCL_5x5_98_USB

PCL_555_98
PCL_545_98
PCL_535_98

usbprint.inf

Windows 
2000/XP

PS \DC555_DC545_DC535
\PS_5X5_NT_W2K_XP

PS_555_NT4_
W2K_XP

PS_545_NT4_
W2K_XP

PS_535_NT4_
W2K_XP

Xdcs555.inf

Xdcs545.inf

Xdcs535.inf

PCL \DC555_DC545_DC535
\PCL_5X5_NT_W2K_XP

PCL_555_NT4_
W2K_XP

PCL_545_NT4_
W2K_XP

PCL_535_NT4_
W2K_XP

DC555pcl.inf

DC545pcl.inf

DC535pcl.inf

Table 2-1:  Windows Printer Drivers

NOTE: PCL 6 printer drivers are available from the Xerox Web site at 
www.Xerox.com.
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Uninstalling the Xerox Printer Installer
To uninstall the Xerox Printer Installer:

1 Click Start > Settings > Control Panel.

2 Double-click Add/Remove Programs. The Add/Remove Programs dialog 
opens.

3 Select Xerox Document Centre from the list of programs.

4 Click Add/Remove. The Xerox Uninstaller dialog appears.

5 Click Next. The uninstall program begins. Upon completion click OK.

6 Select whether to restart your computer now or later. Click Finish.

NOTE: Depending on what components you installed, the uninstaller 
removes the ReadMe, Graphic Arts files, User Guide, and the uninstaller. 
The printer driver and printer are not removed. They must be removed 
manually.
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Uninstalling Windows Printer Drivers
Use the procedures in this section for uninstalling the CentreWare printer drivers.

To uninstall the Windows 95/98/Me/NT printer drivers:

1 At the desktop, click Start > Settings > Printers.

2 Right-click on the icon for the Document Centre you want to delete and select 
Delete. 

3 A confirmation message appears. Click Yes to delete the printer driver.

4 Rebooting your workstation is recommended.

To uninstall the Windows 2000/XP printer drivers:

1 At the desktop, click Start > Settings > Printers.

2 Right-click on the icon for the Document Centre you want to delete and select 
Delete. 

3 A confirmation message appears. Click Yes to delete the printer driver.

4 From the Printers folder, select File > Server Properties.

5 Select the Drivers tab.

6 Select the printer driver and click Remove.

7 Click Yes at the prompt to delete the printer driver. The printer driver is removed.

8 Click Close to exit Printer Server Properties.  

NOTE: Before you uninstall CentreWare Windows printer drivers, ensure that the 
Document Centre you are deleting is not the default printer. If so, select another 
printer as the default.
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Using Windows Printer Drivers

This chapter describes using the CentreWare printer driver features for Microsoft 95/
98/Me, NT 4.0, Windows 2000, and XP users. The procedures described are based on 
printing from Microsoft Word. The procedures for printing from other applications 
may vary.

What�s in this chapter:
! Accessing Printer Driver Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-2

! Printing to the Document Centre  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-3

! Printing Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-4
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Accessing Printer Driver Options 
You can access printer driver options from the Windows Printers folder (Windows 95/
98/Me/NT/2000/XP). When you change the print options from these areas, you 
change the options for all print jobs.

To set print options in Windows:

1 Choose Start > Settings > Printers. The Printers Folder opens.

2 Right-click the icon of the appropriate printer and select one of the following to 
display the printer driver:

! Windows 95/98/Me � Properties 

! Windows NT 4.0 � Document Defaults

! Windows 2000 and XP � Printing Preferences

3 Select the appropriate tabs within the printer driver to specify print options.

4 Click Apply to save your changes.

5 Click OK to close the printer driver.
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Printing to the Document Centre
Use the following procedure for printing from an application (Microsoft Word 95/97). 
Printing from other applications may vary.

To print from within an application:

1 Open the application.

2 Select File > Print from the menu within the application. The Print dialog is 
displayed.

3 Select the appropriate printer from the list of available printers. Click Properties.

4 Select the appropriate tabs within the printer driver and specify your print 
options.

5 Click OK to return to the Print dialog and select any other printing options.

6 Click OK to send the job to the Document Centre.
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Printing Options
The following section discusses how to access and use popular Document Centre 
features. These options are contained in the printer driver tabs (Enhanced driver) or 
within a tree structure (Standard driver). For more information on Standard and 
Enhanced printer drivers, see CentreWare Printer Drivers on page vii.

Accounting Option
CentreWare Accounting allows organizations to track Document Centre use by 
individual users and by account numbers. The printer collects and stores account 
information as jobs are submitted, making cost tracking and reporting an integral part 
of the print submission process.

The Document Centre must be configured for Accounting, and the CentreWare 
printer driver must be configured as well. 

Save Accounting Codes

When the Save Accounting Codes option is selected, the User ID and Account ID 
entries will be saved when printing or faxing. The same ID numbers will be used for 
each job until you enter different numbers.

Conceal User ID

Select Conceal User ID to prevent the User ID from being viewed. When this option 
is selected, all the User ID characters are concealed by displaying asterisks (*).

Conceal Account ID

Select Conceal Account ID to prevent the Account ID from being viewed. When this 
option is selected, all the Account ID characters are concealed by displaying 
asterisks (*).

NOTE: Printing option availability varies for different Document Centre models 
and Windows operating systems. 
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Enabling Accounting

Windows 95/98/Me/NT/2000/XP (Enhanced)

To enable Accounting:

1 Select Start > Settings > Printers. The Printers folder opens.

2 Right-click the icon of the appropriate printer and select one of the following to 
open the printer driver:

! Windows 95/98/Me � Properties

! Windows NT 4.0 � Document Defaults

! Windows 2000/XP � Printing Preferences

3 On the User Preferences tab, check Enable Accounting.

4 Select any Accounting options desired.

5 Click OK to close the printer driver.

6 Close the Printers folder.
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Windows NT/2000/XP (Standard) 

To enable accounting:

1 Select Start > Settings > Printers. The Printers folder opens.

2 Right-click the desired printer and select Properties.

3 On the Device Settings tab, select Accounting from the tree.

4 Select Enabled.

5 Select to enable Save Accounting Codes, Conceal User ID, or Conceal Account 
ID.

6 Click OK. Your driver is now configured for Accounting.

Submitting a Print Job with Accounting Enabled

Windows 95/98/Me/NT/2000XP

To submit a print job using accounting:

1 Open your document and choose File > Print.

2 Choose your printing options.

3 Click Print. The CentreWare Accounting dialog box opens. 

4 Enter your User ID and Account ID, then click OK to print your document. If 
you enter account/user IDs that are incorrect, an error message appears.

NOTE: In Windows 2000, an Administrator must configure the printer driver with 
the accounting policies for concealing or remembering user and account IDs. 
These policies are for every print job that is sent to the Document Centre and 
cannot be changed by individual users. 
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Banner Sheet
The banner sheet contains user and other print job information. It prints before each 
document, separating printed documents in the output trays. Banner sheets can be 
configured to print (or not print) in several places, including the CentreWare printer 
driver, the Document Centre, an application, or network software. 

The CentreWare printer driver (Document Options) default is to print a banner sheet 
with each document printed by the Document Centre. However, simply deselecting 
this option in the printer driver may not guarantee that it will not be printed. The 
Capture Settings tab, Advanced tab, or General tab may also contain banner sheet 
settings. 

When a banner sheet is enabled to print at the Document Centre�s control panel, it 
always prints, regardless of the settings in the CentreWare printer driver or network 
software.

Third-party software applications can also have banner sheet options that enable 
printing of banner sheets with one or all print jobs.

Additionally, network software can be configured to always print banner sheets with 
each print job.  Some organizations may require a banner sheet because of print 
volume.   

See your network or system administrator if you have disabled banner sheet printing 
and a banner sheet is still being printed with your documents. 
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Windows 95/98/Me/NT/2000/XP (Enhanced)
To deselect a banner sheet in the printer driver: 

1 Select Start > Settings > Printers. The Printers folder opens.

2 Right-click the icon of the appropriate printer and select one of the following to 
display the printer driver:

! Windows 95/98/Me � Properties 

! Windows NT 4.0 (Enhanced) � Document Defaults

! Windows 2000/XP (Enhanced) � Printing Preferences

3 Select the Document Options tab. 

4 Deselect the Request Banner Sheet option.

5 Click OK.

6 Click OK to close the driver.

A banner sheet will not be printed with any print jobs. 

Windows NT (Standard)

To deselect a banner sheet in the printer driver: 

1 Select Start > Settings > Printers. The Printers folder opens.

2 Right-click the desired printer and select Document Defaults.

3 Select the Advanced tab.

4 Expand Document Options in the options tree.

5 Select Banner Page and choose Disable.

6 Click OK to close the printer driver.

A banner sheet will not be printed with any print jobs.

NOTE: If the Document Centre is configured to print a banner sheet with 
each print job, this setting overrides the printer driver setting. Some 
applications may override this setting or can be used to enable a banner 
sheet for a specific job. Contact your administrator if a banner sheet is still 
printed after changing the setting in the printer driver.
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Windows 2000/XP (Standard)

To deselect a banner sheet in the printer driver: 

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Click Advanced.

4 Expand Document Options > Printer Features in the options tree. 

5 Select Banner Page and choose Disabled.

6 Click OK to close the Advanced Options dialog.

7 Click OK to exit the printer driver. 
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Booklet Creation Option
Booklet creation enables you to print documents as small booklets. Two images are 
printed on both sides of each sheet of paper. The pages are reordered sequentially and 
are orientated so that when folded, the paging is correct.  

TIP: Keep in mind that the layout of a booklet differs in comparison to the layout of a 
1-up document. Line wrapping and page breaks will vary.

Windows 95/98/Me/NT/2000/XP (Enhanced)

To print a booklet:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties.

3 On the Layout/Watermark tab, select Booklet Creation from the Page Layout 
Options drop-down list.

(For NT PCL, on the Layout tab, select the Booklet Creation radio button and 
enter a Gutter and Creep setting.)

4 Click OK to close the printer driver. 

5 Click OK to close the Print Setup dialog.

6 Click Print. Your document is sent to the printer. 

NOTE: The booklet option prints to the same size paper. A print job that 
has multiple size pages will result in clipped images in the printed 
document.
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Windows NT/2000/XP (Standard)

To print a booklet:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Advanced tab (NT) button (2000/XP).

4 Expand Document Options > Booklet Creation in the options tree.

5 Select Booklet Creation and choose Enabled.

6 Select AutoBooklet Layout and choose Enabled.

7 Click OK to close the dialog and print.

NOTE: The Booklet Creation option is not available in NT PCL 
(standard).
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Collate and Staple Options
These options enable you to collate and/or staple your document sets. Stapling 
options include 1 or 2 staples. 

Collate prints and delivers two or more copies of a document as separate document 
sets (1,2,3... 1,2,3...). Uncollated prints and delivers two or more copies of a 
document as separate sets of each page (1, 1, 1... 2, 2, 2... 3, 3, 3...). 

Windows 95/98/Me/NT/2000/XP (Enhanced)

To collate and staple a document:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select Paper/Output.

4 Select an option from Output/Stapling.

5 Click OK to close the printer driver.

6 Click OK to send your document to print.
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Windows NT (Standard)

To collate and staple a document:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Page Setup tab.

4 Type in the number of Copies. This activates and enables Collate Copies.

5 Select the Advanced tab.

6 Expand Document Options > Printer Features in the options tree.

7 Select Stapling and choose an option.

8 Click OK to close the printer driver.

9 Click OK to send your document to print.
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Windows 2000/XP (Standard)
To collate and staple a document:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Click Advanced.

4 Expand Document Options > Printer Features in the options tree. 

5 Select a Stapling option.

6 Select Paper/Output in the options tree. In Copy Count enter the number of 
copies to print. This activates and enables Collated.

7 Click OK to close the Advanced options dialog.

8 Click OK to close the Printing Preferences dialog.

9 Click OK to print.
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Cover Option
CentreWare printer drivers enable you to choose a different media type and color for 
the first page or first and last (cover) pages of your document. This does not affect the 
paper selection for the body of the document. If you specify a paper/media type that is 
not currently loaded in the printer, the job will be held in the printer until the required 
paper/media is loaded in one of the trays.

TIP: To add a cover to a booklet choose Front Cover. When booklets are folded, 
the back cover is actually the same sheet of paper as the front cover. Therefore, the 
Front Cover selection also applies to the Back Cover when Booklet Creation is 
selected.

Windows 95/98/Me/NT2000/XP (Enhanced)

To create covers:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 On the Paper/Output tab, click Select Paper and choose the Covers tab (or, 
Covers and Advanced and then select the Covers tab).

4 Select the desired cover options for your document.

5 Click OK to close the printer driver. Then click OK to print.

NOTE: For single-sided printing, the first and last pages of your 
document will print on the covers.

For 2-sided printing, the first page of your document is printed on the front 
of the cover and the second page is printed on the back of the front cover. 
You should insert a blank page (page 2) if you do not want the back of the 
front cover to be printed.
The last page of your document will always print on the back of the back 
cover page. If the document contains an odd number of pages, the printer 
will automatically insert an extra page before the last page in your 
document. You should insert a blank page at the end of your document if 
you do not want the back of the back cover to be printed.
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Windows NT (Standard)

To create covers:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Advanced tab.

4 Expand Document Options > Covers in the options tree.

5 Select options from Covers, Cover Media Type, and Cover Media Color.

6 Click OK to close the printer driver.

7 Click OK to print.

Windows 2000/XP (Standard)

To create covers:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties. 

3 Click Advanced. The Advanced Options dialog opens.

4 Expand Document Options > Covers in the options tree.

5 Select Covers and an option for Front or Front and Back Covers.

6 Select the media type and color for the cover.

7 Click OK to close the printer driver. 

8 Click OK to print. 
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Custom Paper Size Option
The Custom Sizes option enables you to specify custom paper sizes. Your Document 
Centre accepts individual media of different sizes using a manual feed tray, such as 
the Envelope Tray, or an adjustable paper tray, such as the Bypass Tray.  

If you are printing a custom paper size, it must be configured before printing or a 
media fault error occurs.    

Windows 95/98/Me/NT/2000/XP (Enhanced)

To specify a custom paper size:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Click the User Preferences tab. 

4 Under Paper Size, click Custom Sizes. The Custom Sizes dialog box opens.

5 Select one of the Custom Size radio buttons, if available.

6 Select the options for paper Width and Length, then choose Inches or 
Millimeters.

7 Click OK to close the dialog.

8 Click OK to close the printer driver, and then click OK to print your document.

NOTES: 1) The Custom Sizes feature is not supported on all Document 
Centre models. 

2) You should select custom paper sizes from the printer driver rather 
than the application that you are using.
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Windows NT (Standard)

To specify a custom paper size:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Advanced tab.

4 From Media, select a Custom option.

5 Select the Page Setup tab.

6 From the Paper Size drop-down list, select one of the following:

! For a PCL driver, select a Paper Size option from the drop down list.

! For a PostScript driver, select PostScript Custom Page Size. The PostScript 
Edit Custom Page Size Definition dialog appears.

a) Make selections, such as dimensions, and click OK. 

b) If you need to edit the custom paper size, click Edit Custom Page Size 
which appears to the right of the Paper Size drop-down list when the 
custom size is selected.

7 Click OK to close the printer driver.

8 Click OK to print.
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Windows 2000/XP (Standard)

To specify a custom paper size:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties. 

3 Select the Paper/Quality tab.

4 From the Media drop-down list, choose a custom paper size (Custom 1-7) 

5 Click Advanced. The Advanced Options dialog opens.

6 Select Paper Size from the options tree and do one of the following:

! For a PCL driver, select a paper size option from the drop down list.

! For a PostScript driver, select PostScript Custom Page Size. The PostScript 
Edit Custom Page Size Definition dialog appears.

a) Make selections, such as dimensions, and click OK. 

b) If you need to edit the custom paper size, click Edit Custom Page Size, 
which appears to the right of the Paper Size drop-down list when the 
custom size is selected.

7 Click OK to close the Advanced Options dialog.

8 Click OK to exit the printer driver.
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Delayed Print Option
This option enables you to print documents at a specific time. The job is held at the 
Document Centre until the specified time and printed.

Windows 95/98/Me/NT/2000/XP (Enhanced)

To send a delayed print job:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Paper/Output tab.

4 Under the Job Type heading, select Delayed Print.

5 Click the Delayed Print Setup button.

6 In the Time box, enter the time you would like this job to print. Click OK.

7 Click OK to close the printer driver. 

8 Click OK to send your document to the printer.

The document is held at the Document Centre until the defined print time when it is 
released and printed.

Windows NT (Standard)

To send a delayed print job:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Advanced tab.

4 Expand Document Options in the options tree.

5 From Job Type, select Delay Print from the drop-down list. 

6 Enter the time you would like this job to print. Click OK.

7 Click OK to close the printer driver. 

8 Click OK to send your document to the printer.

The document is held at the Document Centre until the defined print time when it is 
released and printed.
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Windows 2000/XP (Standard)

To send a delayed print job:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Click Advanced. The Advanced Options dialog opens.

4 Expand Document Options in the options tree.

5 From Job Type, select Delay Print. The Delayed Print Setup dialog appears.

6 Enter the time you would like this job to print and click OK. 

7 Click OK to close Advanced Options dialog.

8 Click OK to close the printer driver.

9 Click OK to submit the print job.

The document is held at the Document Centre until the defined print time when it is 
released and printed.    

NOTE: The Delayed Print settings remain for all print jobs until you select a 
different Job Type and exit the printer driver. 
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Finisher Options
Finisher options for Document Centre models 555/545/535 include:

Table 3-1 lists the Finisher units and the finishing options each offers. The Finisher 
units are mutually exclusive, that is, only one Finisher unit may be installed at a time. 
Check with your Xerox representative to determine which Finisher units are available 
for your Document Centre.

! Hole Punching ! Offsetting ! Stapling

Finisher 
Unit (DC 555/
545/535)

Output 
Tray

C
apacity 

(Sheets of
 paper)

O
ffsetting

H
ole Punch

Stapling

Offsetting Tray Offset Catch 
Tray

500 x

2000 Sheet 
Stapler/Stacker

 (without punch)

Top Output 
Tray

250

Stacker Tray 2000 x x

2000 Sheet 
Stapler/ Stacker 

(with punch)

Top Output 
Tray

250

Stacker Tray 2000 x x x

Table 3-1:  Finisher Options
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Hole Punching
The hole punch mechanism creates two, three, or four holes depending on how your 
Finisher is equipped. The number of holes created by the punch cannot be changed 
through your software. See Hole Punch Option on page 3-24. 

Offsetting
This feature slightly offsets each set of a multiple copy print job from one another in 
either the Offset Catch Tray or Stacker Tray. This often makes it easier to sort and 
handle documents when you are printing several copies.

Stapling
Document Centre models 555/545/535 support stapling using one or two staples. See 
Collate and Staple Options on page 3-12.

! Collated, 1 Staple places a staple in the upper left corner for both Long 
Edge Feed (LEF) and Short Edge Feed (SEF) portrait or landscape 
documents.

! Collated, 2 Staples places a second staple on the lower left side of the 
document. 

NOTE: Stapling positions may vary depending on other selections, such 
as rotation or N-up (multiple pages on a single sheet) settings.
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Hole Punch Option 
Finishers equipped with a hole punch mechanism create either two, three, or four 
holes depending on the kind of hole punch mechanism installed. The number of holes 
created by the punch cannot be changed through your software.

Hole Punching supports the following media:

Windows 95/98/Me/NT/2000/XP (Enhanced)

To request hole punching:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties.

3 On the Paper/Output tab, select an option from the Fold/Punch Options.

4 Click OK to return to the Print dialog. 

5 Click OK to send your document to print. 

! 11 x 17 ! A3

! 8.5 x 11 Letter (LEF) ! A4 (LEF)
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Windows NT/2000/XP (Standard)

To request hole punching:

1 Choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Click the Advanced tab (NT) button (2000/XP).

4 Expand Document Options > Printer Features in the options tree.

5 Select Hole Punch and choose Enabled.

6 (For NT) Click OK to close the printer driver.
(For 2000/XP) Click OK to close the Advanced Options dialog and OK to close 
the Document Properties dialog.

7 Click OK to print.
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Media Options
The Document Centre provides many options for media type, size, and color.  You 
choose media options for printed documents, depending on your operating 
environment, by one of the following methods.

To specify media options for printing:
! Windows 95/98/Me/NT/2000/XP (Enhanced)

Access a CentreWare printer driver and click Select Paper on the Paper/
Output tab.

! Windows NT (Standard)

Access a CentreWare printer driver and select media options from the tree 
(Paper Size and Media) in the Advanced tab.

! Windows 2000/XP (Standard)

Access a CentreWare printer driver and select media options from Paper/
Quality tab. Click Advanced and select other media options from the tree 
under Paper/Output and Document Options.

Media Configuration on the Document Centre
Before the media selections are made available in the printer driver, they are 
configured on the Document Centre using the control panel. Certain media types, 
sizes, and colors are assigned to specific paper trays. A white paper in a standard size, 
such as 8.5 x 11 or A4, should be assigned to at least one tray on the Document Centre 
as the default paper. If not, a media fault error may occur.
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Assigning Media to Trays in the Printer Driver
The printer driver media and paper trays should reflect what is configured in the 
Document Centre. If another type of paper is loaded into a tray which is already 
assigned a specific type of paper, a conflict can occur. 

For example, if letterhead is loaded into a tray that is assigned to standard white 
paper, and the printer driver uses the tray for standard white paper input, a mismatch 
occurs. A print job that requires standard white paper will be held in the queue until 
the correct media needed for the job is loaded in the Document Centre. 

If you are using the Bi-Directional printer drivers, the driver automatically detects the 
media and paper tray assignments. See Bi-Directional Printer Drivers on page 2-11 
for more information.

To specify media assignments in the printer driver:
! Windows 95/98/Me/NT/2000/XP (Enhanced)

Select Start > Settings > Printers. Right-click on a printer driver and select 
Properties. Select the System Configuration tab. Under Paper in this 
Device, assign media types to specific trays.

! Windows NT (Standard)

Select Start > Settings > Printers. Right-click on a printer driver and select 
Document Defaults. Select the Advanced tab. Under Paper/Output select 
Paper Size, Media, and Paper Source options.

! 2000/XP (Standard)

Select Start > Settings > Printers. Right-click on a printer driver and select 
Printing Preferences. Select the Paper/Quality tab. Under Tray Selection 
assign media types to specific trays.

TIP: To avoid media conflicts/faults, it is important to make sure that the media 
loaded into the paper trays matches the paper tray media assignment and the paper 
tray/media settings in the printer driver.
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CentreWare Monitoring Option

CentreWare Monitoring enables you to monitor the progress of your print jobs from 
the convenience of your desktop. 

The CentreWare Monitor tracks the progress of each job throughout its life cycle and 
provides you with complete status information. It will inform you when your job is 
completed, or alert you if there is a problem that requires your attention.

Windows 95/98/Me/NT/2000/XP (Enhanced)

To monitor documents using CentreWare monitoring:

1 Select Start > Settings > Printers. The Printers folder opens.

2 Right-click the appropriate printer from the list of available printers and select 
Properties (95/98/Me) or Document Defaults (NT) or Printing Preferences 
(2000/XP).

3 Select the User Preferences tab.

4 Select Monitor My Jobs. 

5 Click OK to close the User Preferences dialog and return to the Printers folder.

6 Close the Printers folder. 

Jobs that you submit to this Document Centre automatically launch the CentreWare 
monitor.

NOTE: This option requires use of the CentreWare Conductor, which is installed 
with CentreWare Network Services. 
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Windows NT (Standard) 

To monitor documents using CentreWare monitoring:

1 Select Start > Settings > Printers. The Printers folder opens.

2 Right-click the appropriate printer from the list of available printers and select 
Document Defaults.

3 Select the Advanced tab. The Advanced Options dialog opens.

4 Expand Document Options in the options tree. 

5 Select Enable Document Monitoring and choose On.

6 Click OK to close the printer driver.

Jobs that you submit to this Document Centre automatically launch the CentreWare 
monitor.
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Windows 2000/XP (Standard)

To monitor documents using CentreWare monitoring:

1 Select Start > Settings > Printers. The Printers folder opens.

2 Right-click the appropriate printer from the list of available printers and select 
Printing Preferences.

3 Click Advanced. The Advanced Options dialog opens.

4 Expand Document Options in the options tree. 

5 Select Enable Document Monitoring and choose On.

6 Click OK to close the printer driver. 

Jobs that you submit to this Document Centre automatically launch the CentreWare 
monitor.
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N-Up Printing Option
Multiple-Up (N-Up) printing is used to print more than one page of a document on a 
single page. 
Keep in mind that the layout of an N-up document differs in comparison to the layout of 
a 1-up document. Line wrapping and page breaks will vary.

Windows 95/98/Me/NT2000/XP (Enhanced)

To print multiple images on each page:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 On the Layout/Watermark tab, make the appropriate selection in the Page 
Layout > Options drop-down list.

(For NT PCL, on the Layout tab, select the Multiple-up radio button. Choose 
from the Multiple-up options.)

4 Click OK to close the printer driver. 

5 Click OK to send your document to the printer.

Windows NT (Standard)
To print multiple images on each page:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Advanced tab. The Advanced Options dialog opens.

4 Expand Document Options in the options tree.

5 Select Multiple-up and the number of pages to print on a sheet.

6 Click OK to close the printer driver.

7 Click OK to print.
Printing Options 3-31



3-32 U
Windows 2000/XP (Standard)

To print multiple images on each page:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties. 

3 Click Advanced. The Advanced Options dialog opens.

4 Expand Document Options in the options tree.

5 Select Multiple-up and the number of pages to print on a sheet.

6 Click OK.

7 Click OK to print your document.
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Sample Set (Proof Print) Option
The Sample Set feature enables you to send a multiple-set job to the Document 
Centre, print one copy of the document, and hold the remaining sets in the Document 
Centre print queue.

Windows 95/98/Me/NT/2000/XP (Enhanced)

To print a sample set:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 On the Paper/Output tab, select Sample Set (or Sample Print) as your 
Job Type.

4 Select the total number of copies (sets) you would like to print. Choose any other 
print options you want in the printer driver.

5 Click OK to close the printer driver. 

6 Click OK to submit your job to the Document Centre. One set of the document 
prints and the remaining sets are held at the Document Centre.

After proofing the Sample Set, you can print or delete the remaining sets. See 
Releasing or Deleting a Job at the Document Centre on page 3-35 for instructions on 
how to delete or release a document. 

NOTE: Documents held for an extended period of time are deleted automatically. 
The time limit is configured by the Network Administrator.
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Windows NT (Standard)

To print a Sample Set print job:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Advanced tab. The Advanced Options dialog opens.

4 Expand Document Options in the options tree.

5 From Job Type, select Sample Set from the drop-down list.

6 On the Page Setup tab, select the total number of copies (sets) you would like to 
print. Choose any other print options you want in the printer driver.

7 Click OK to close the printer driver. 

8 Click OK to submit your job to the Document Centre. One set of the document 
prints and the remaining sets are held at the Document Centre.

After proofing the Sample Set, you can print or delete the remaining sets. See 
Releasing or Deleting a Job at the Document Centre on page 3-35 for instructions on 
how to delete or release a document. 
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Windows 2000/XP (Standard)
To print a sample set:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Click Advanced. The Advanced Options dialog opens.

4 Expand Document Options in the options tree.

5 Select Job Type and choose Sample Set from the options.

6 From Paper/Output in the options tree, select Copy Count.

7 Select the number of copies (sets) to print.

8 Click OK to close the Advanced Options dialog.

9 Click OK to close the printer driver. 

10 Click OK to submit your job to the Document Centre. One set of the document 
prints, and the remaining sets are held at the Document Centre.

After proofing the Sample Set, you can print or delete the remaining sets. 

Releasing or Deleting a Job at the Document Centre
1 Go to the Document Centre control panel/touch screen and press Job Status.

2 Find your document on the list of All Incomplete Jobs. To select the job, press 
the name until it highlights.

3 On the screen that appears, press Delete to delete the job or press Release to 
release the job for printing.
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Secure Print Option
This feature automatically holds your document within the Document Centre internal 
queue until you are ready to retrieve your job.

To send a Secure Print job, you need an identification number. This number of four to 
ten digits (as determined by your system administrator) can be any numeric value 
using the numbers 0 through 9.

Windows 95/98/Me/NT/2000/XP (Enhanced)

To print secure documents:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 On the Paper/Output tab, select Secure Print from the Job Type drop-
down list.

4 Click Secure Print Setup. The Secure Print Setup dialog opens.

5 Enter an identification number in the dialog box.

6 Re-enter the same code again to confirm your Secure Print ID.

7 Click OK to close the Secure Print Setup dialog. Click OK to submit the print 
job. The job is held at the Document Centre. See Releasing a Secure Print Job at 
the Document Centre on page 3-38 to print the document.

NOTE: The Secure Print settings remain for all print jobs until you select a 
different Job Type and exit the printer driver. 
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Windows NT (Standard)

To print a secure document:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Advanced tab.

4 Expand Document Options in the options tree.

5 Select Job Type and choose Secure Print from the options. The Secure Print 
Setup dialog appears.

6 Enter an identification number in the dialog box.

7 Re-enter the same code to confirm your Secure Print ID.

8 Click OK to close the Secure Print Setup dialog.

9 Click OK to close the printer driver. 

10 Click OK to submit the print job. The job is held at the Document Centre. See 
Releasing a Secure Print Job at the Document Centre on page 3-38 to print 
the document.

NOTE: The Secure Print settings remain for all print jobs until you select a 
different Job Type and exit the printer driver. 
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Windows 2000/XP (Standard)

To send a secure print job:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Click Advanced. The Advanced Options dialog opens.

4 Expand Document Options in the options tree.

5 Select Job Type and choose Secure Print from the options. The Secure Print 
Setup dialog appears.

6 Type an identification number in the dialog box.

7 Re-enter the same code to confirm your identification number and click OK.

8 Click OK to close the Advanced Options dialog.

9 Click OK to close the printer driver.

10 Click OK to submit the print job. The job is held at the Document Centre. 
Perform the following procedure to release the document.

Releasing a Secure Print Job at the Document Centre
1 Go to the Document Centre control panel/touch screen and press Job Status.

2 Find your document on the list of All Incomplete Jobs. Press the name until it 
highlights, which selects the job.

3 On the screen that appears, press Release to continue with the job.

4 Enter your identification number on the numeric keypad.

5 Press Enter. Your document prints.

NOTE: The Secure Print settings remain for all print jobs until you select a 
different Job Type and exit the printer driver. 
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Transparency Separators Option
This option enables you to print separator pages for transparencies on your Document 
Centre. The separator pages can be blank or printed.

Windows 95/98/Me/NT/2000/XP (Enhanced)
To specify separators for transparencies:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 From the Paper/Output tab, click Select Paper.

4 Do one of the following:

! From the drop-down list, select Type and specify Transparency.

-Or-

! Depending on the type of printer driver you have, select the Document 
Options (or Body or Document) tab. From the Type drop-down list select 
Transparency.

5 Click OK to close the printer driver. Then click OK to print.

Windows NT (Standard)

To specify separators for transparencies:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Advanced tab.

4 Expand Document Options > Transparency Separators in the options tree.

5 Select Transparency Separators and then the type (printed or blank) from the 
drop-down list.

6 Select color options for the separators from the drop-down list.

7 Click OK to close the printer driver. Then click OK to print.
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Windows 2000/XP (Standard)

To specify separators for transparencies:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties. 

3 Select the Paper/Quality tab and specify Transparencies from the Media drop-
down list.

4 Click Advanced. The Advanced Options dialog opens.

5 Expand Document Options > Transparency Separators in the options tree.

6 Select Transparency Separators and specify printed or blank separators.

7 Select Transparency Separator Color and specify a color for the separators.

8 Click OK to close the Advanced Options dialog.

9 Click OK to close the printer driver. 
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Two-Sided Printing (Duplex) Option
This option enables you to print your document on both sides of the paper. Options 
include:

! 2-Sided, Flip on Long Edge to print your document so it opens like a book.

! 2-Sided, Flip on Short Edge to print your document so it opens like a 
calendar.

Windows 95/98/Me/NT/2000/XP (Enhanced)

To print a two-sided document:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select Paper/Output.

4 Select an option from 2-Sided Printing.   

5 Click OK to close the printer driver.

6 Click OK to print.
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Windows NT (Standard)

To print a two-sided document:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Page Setup tab.

4 Select a Print on Both Sides (Duplex Printing) option.

5 Click OK to close the printer dialog.

6 Click OK to print.

Windows 2000/XP (Standard)
To print a two-sided document:

1 Open your document and choose File > Print.

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select Layout.

4 Select a Print on Both Sides (Duplex) option. 

5 Click OK to close the printer driver.

6 Click OK to print.
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Watermark Option
The Watermark option, accessed from the Layout/Watermark or Watermarks 
(NT PCL) tab, lets you create and print foreground/background text on the first page 
or every page of a document. The Watermark definitions you create can be used on 
any document. 

The Watermark list box contains a list of all the watermarks currently available. If you 
select a watermark from this list, it prints on your document. 

Some Document Centre printer drivers support bitmap watermarks. You can select, 
scale, and position a graphic bitmap for use as a watermark. 

Printing a Watermark

Windows 95/98/Me/NT/2000/XP (Enhanced)

To print a watermark:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties.

3 On the Layout/Watermark tab (or Watermarks tab), select the desired 
watermark from the list and any other print options you would like to apply to 
this watermark. Click OK to close the tab.

4 Click OK to close the print dialog and send your document to print.

NOTES:  1) Some applications may not support Watermark printing. 

2) Watermarks are not available in all CentreWare printer drivers.
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Windows NT (Standard)

To print a watermark:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Advanced tab. The Advanced Options dialog opens.

4 Expand Document Options > Watermarks in the options tree.

5 Select Watermark and the desired watermark option from the drop-down list. 

6 Click OK to close the dialog.

7 Select Watermark optional printing options (First Page Only or Print in 
Foreground) from the tree. 

8 Click OK to close the printer driver.

9 Click OK to print.

Windows 2000/XP (Standard)

To print a watermark:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties. 

3 Click Advanced. The Advanced Options dialog opens.

4 Expand Document Options > Watermark from the options tree.

5 Select Watermark and choose a watermark option from the drop-down list.

6 Select any other watermark options (First Page Only or Print in Foreground) 
from the tree. 

7 Click OK to close the Advanced Options dialog.

8 Click OK to close the printer driver.

9 Click OK to print your document with the watermark.
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Creating or Editing a Watermark
If your desired watermark is not on the list of watermarks, click New on the Layout/
Watermark tab to create a new one. Or, you may select an existing watermark, then 
click Edit to change it. 

Windows 95/98/Me/NT/2000/XP (Enhanced)

To create a watermark:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties.

3 On the Layout/Watermark tab, click New (or select the Watermarks tab) to 
open the Watermark Editor.

4 Choose one of the following:

! Select Text for a text watermark. Add the text you want to the box, then 
choose any desired options. 

! If available, select Bitmap and select a bitmap file, then choose any desired 
options. 

In some cases, you may also preview how your watermark appears with a 
specific Paper Size and Orientation.

5 Click OK to close the Watermark Editor.

6 On the Layout/Watermark tab, make sure your watermark is selected on the 
list, then choose any other desired print options.

7 Click OK to return to the print dialog. 

8 Click OK to send your document to print.

NOTE: The Preview display does not always match the actual output.
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Windows NT (Standard)

To create a watermark:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties.

3 Select the Advanced tab. The Advanced Options dialog opens.

4 Expand Document Options > Watermarks in the options tree.

5 Select Watermark and New from the drop-down list to open the Watermark 
Editor.

6 Choose one of the following:

! Select Text for a text watermark. Add the text you want to the box, then 
choose any desired options. 

! If available, select Bitmap and select a bitmap file, then choose any desired 
options. 

In some cases, you may also preview how your watermark appears with a 
specific Paper Size and Orientation.

7 Click OK to close the Watermark Editor. 

8 Choose any other print options.

9 Click OK to close the Advanced Options dialog.

10 Click OK to close the printer driver.

NOTE: The Preview display does not always match the actual output.
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Windows 2000/XP (Standard)

To create a watermark:

1 Open your document and choose File > Print. 

2 Select the appropriate printer from the list of available printers. Click Properties. 

3 Click Advanced. The Advanced Options dialog opens.

4 Expand Document Options > Watermark in the options tree.

5 Select Watermark and New from the drop-down list to open the Watermark 
Editor.

6 Choose one of the following:

! Select Text for a text watermark. Add the text you want to the box, then 
choose any desired options. 

! If available, select Bitmap and select a bitmap file, then choose any desired 
options. 

In some cases, you may also preview how your watermark appears with a 
specific Paper Size and Orientation.

7 Click OK to close the Watermark Editor.

8 Choose any other print options.

9 Click OK to close the Advanced Options dialog.

10 Click OK to close the printer driver and print your document with the watermark.

NOTE: The Preview display does not always match the actual output.
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Installing and Using the
Font Management Utility

The Font Management Utility is a tool used to maintain fonts on your network 
printers. Font lists can be developed and modified for use by all your printers. For 
example, if you have special fonts that are used in documents but are not readily 
available on your printer(s), you can use the Font Management Utility to download 
the required fonts to the printers. Using the utility, fonts may be viewed, printed, 
downloaded to printers, or exported to a file. You may also maintain printer lists for 
font management.   

What�s in this chapter:
! Installing the Font Management Utility  . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2

! Uninstalling the Font Management Utility . . . . . . . . . . . . . . . . . . . . . . . . 4-3

! Accessing the Font Management Utility . . . . . . . . . . . . . . . . . . . . . . . . . . 4-4

! Using the Font Management Utility . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-4

! Adding A Printer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-5

! Printing a Printer�s Font List  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-6
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Installing the Font Management Utility
To install the utility:

1 Insert the CentreWare Print and Fax Drivers CD into the appropriate drive. The 
Autoplay program starts.

2 Click Utilities.

3 Click Install Font Management Utility.

4 The install wizard opens. Click Next.

5 Select to accept the license agreement.  Click Next.

6 Type the user name and organization. 

7 Select the Setup type: Complete or Custom.  Click Next.

8 Click Install to install the utility on the workstation.

9 Click Finish to exit the install wizard.   

The installation is complete.
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Uninstalling the Font Management Utility
The Font Management Utility has a maintenance program which can uninstall, 
modify, and/or repair the application.

To uninstall the utility:

1 Locate the Setup file and double-click.

2 Click Next.

3 Select Remove. Click Next.

4 Click Remove.

The Font Management Utility is removed from your system.

To modify the utility:

1 Locate the Setup file and double-click.

2 Click Next.

3 Select Modify. Click Next.

4 Select an application in the tree for modification. Click Next.

5 Click Install.

To repair the utility:

1 Locate the Setup file and double-click.

2 Click Next.

3 Select Repair.

4 Click Install.
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Accessing the Font Management Utility
To access the utility in Windows 95/98/Me/NT/2000/XP:

Select Programs > Xerox Font Management Utility > Font Management 
Utility.

Using the Font Management Utility
Printer List
The printer list displays in the Select Printers list box on the main Font Management 
Utility dialog. The printer list consists of all mapped printer connections for the client 
workstation. When a printer is selected, its configuration options appear in the Printer 
Description area of the dialog. 

Selecting a Printer
You select a printer for font management by clicking the check box next to the printer 
name. When the printer is selected, it is available for font management operations, 
such as font downloading.
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Adding A Printer
On the main CentreWare Font Management Utility dialog, a list of printers that you 
can access appears. If a printer you want to access is not listed, click the Add Printer 
button to add it to your list.

To add a printer:

1 Click Add Printer. The Add Printer Options dialog appears.

2 Enter the Host Address. Click Add Printer.

Figure 4-1:  CentreWare Font Management Utiltiy Dialog
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Printing a Printer�s Font List
You can print a listing of PCL and PostScript fonts that reside on a selected printer.

PCL Font List

To print a list of PCL fonts:

1 On the main Font Management Utility dialog, select a printer.

2 Click Print Font List.

3 From the menu, select PCL Font List to print a listing of PCL fonts that 
currently reside on the printer.

PostScript Font List

To print a list of PostScript fonts:

1 On the main Font Management Utility dialog, select a printer.

2 Click Print Font List.

3 From the menu, select PostScript Font List to print a listing of PostScript fonts 
that currently reside on the printer.
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Working with Font Lists
You can view, edit, or print a font list using the Printer Font List dialog. Font lists can 
be filtered to display only specific types of fonts. You then can print the font list or 
view. Fonts may also be added or deleted from this dialog.

Fonts can be filtered by these categories: PostScript, PCL, permanent fonts, or 
downloaded fonts.  

Figure 4-2:  Font List Dialog
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Valid Fonts
The following font types are viewed in a printer�s font list:

! Permanent Base Fonts

! Downloadable Non-volatile Storage Fonts (NVS)

! Downloadable RAM Fonts

! Temporary Downloadable Fonts

The following fonts are downloadable by the Font Download Utility:

! Adobe Type 1 (PostScript Outline)

! Adobe Type 3 (PostScript User/Bitmap)

! Adobe Type 42 (PostScript True Type)

! PCL 0

! PCL 15 (True Type)

! Windows True Type (converted to PostScript or PCL)

NOTE: Only downloadable and temporary fonts can be removed from 
the printer�s Font List.
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Viewing a Font List

To view a font list for a selected printer:

1 On the main Font Management Utility dialog, select a printer.

2 Click View/Edit Font List. The Printer Font List dialog appears.

3 Select a filter from the View by Font Type drop-down list. The fonts that reside 
on the selected printer display in the Resources on Printer list box. 

4 To view the fonts that reside on another printer, select a printer from the Selected 
Printers drop-down list.

Editing a Font List

Deleting a Font

To delete a font:

1 On the main Font Management Utility dialog, select a printer.

2 Click View/Edit Font List. The Printer Font List dialog appears.

3 To delete a font, select a font and click Delete Font. You can select multiple 
fonts.

4 Click Yes in the confirm dialog to perform the deletion. The font is removed from 
the printer.

NOTE: Permanent base fonts cannot be deleted from printers.
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Adding a Font

To add a font:

1 On the main Font Management Utility dialog, select a printer.

2 Click View/Edit Font List. The Printer Font List dialog appears.

3 Click Add Font. The Resource Manager dialog opens, enabling you to add fonts 
to the Resources list.

4 Click Add to List. The Open dialog appears.

5 Select a file type and directory that contains fonts.

6 Select the desired fonts and click Open. The fonts are added to the Resources 
list.

Printing a Font List
There are two choices for printing the font list of a selected printer: 

You can print a system font list from a selected printer, which prints a sample of the 
actual fonts (Click Print Font List on the main Font Management Utility diaog), or 
simply print the font names of any printer displayed in the Printer Font List dialog.

To print a font list from the Printer Font List:

1 On the main Font Management Utility dialog, select a printer.

2 Click View/Edit Font List. The Printer Font List dialog appears.

3 For a selected printer, select the desired filter for the font list from the View by 
Font Types list box. The fonts appear in the Resources on Printer list.

4 Click Print Report. The Print dialog opens.

5 Choose your print options and click OK. The fonts and their characteristics 
displayed in the Resources on Printer list prints.
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Manage Resources
The Font Management Utility enables you to download fonts to one or multiple 
printers or export fonts to a file using the Resource Manager dialog. You can also 
view and/or modify the listing of fonts (permanent, temporary, downloaded, or not 
downloaded). The printer list may be modified as well. 

View Resources

To view a listing of resources:

1 On the main Font Management Utility dialog, select a printer, then click Manage 
Resources. The Resource Manager dialog opens.

2 Select a printer in the Selected Printer list box. 

3 Choose a Resource Location, either Printer Hard Disk or Printer Flash (SIMM) if 
configured.

Available fonts are displayed in the Resources list box, including the font file name, 
font name, resource type (PCL or PostScript font), and persistence (downloaded, not 
downloaded, temporary, or permanent).  

Figure 4-3:  Resource Manager Dialog
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Edit Resources
You can change the fonts that are listed in the Resource Manager dialog by adding or 
removing fonts from the resources list. 

Removing Fonts from the Resources List

To remove a font:

1 In the Resources list box, select the fonts that you wish to delete. 

2 Click Remove from list.

The fonts are deleted.

Adding Fonts to the Resources List

To add a font:

1 Click Add to List. The Open dialog appears.

2 Select a font file to add to the printer list.

3 Click Open.

The font is added to the Resources List and is available for downloading or exporting.
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Editing the Printer List

To change the printers that are listed in the Manage Resources dialog:

1 On the Resource Manager dialog, click Edit Printer List.

2 Select or deselect printers by clicking the check box next to the printer name.

3 Click Apply.

Figure 4-4:  Edit Printer List Dialog
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Downloading Fonts to a Printer
One or multiple fonts may be downloaded to one or multiple printers that are listed in 
the printer list.

To download fonts:

1 In the Seclected Printers Box, on the Resource Manager dialog, add the printers 
to which you want to download fonts. 

2 Select the Resource Location to which the fonts will be downloaded, either 
Printer Hard Disk or Printer Flash (SIMM) if configured.

3 Select the fonts that you want to download. The Font Management Utility 
displays the file names, font name, types, and persistence of the fonts to be 
downloaded. If Windows True Type Fonts are selected, the utility prompts you to 
select the interpreters (PCL or PostScript or both) for which the fonts are to be 
made available.

4 Click Download to Printer.

The selected fonts begin downloading to the selected printers. The Font Management 
Utility performs a validity check on fonts that are downloading. 

If a font cannot be downloaded, for example if a font file is invalid, an error message 
appears. If the Font Management Utility determines that a printer�s interpreter will 
not support a selected font, the font will not be downloaded. The status will change  in 
the Persistence column of the Resources list box, indicating whether that font was 
successfully downloaded. 

If fonts are already installed on a printer, you will be prompted or a warning message 
will appear indicating this condition. 

When the download is complete, a message appears stating that the process finished 
successfully.
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Exporting Fonts to a File

To export fonts to a Print-ready (.prn) file:

1 Select a printer from the list.

2 Click Manage Resources.

3 Select either Printer Hard Disk or Printer Flash (SIMM), if configured, for the 
location of the fonts on the printer.

4 The available fonts appear in the Resources area of the dialog. Select the fonts 
that you want to export to a file. 

5 Click Export to File. 

6 In the Save As dialog that appears, type the file name and the directory location 
where the file will be saved.

7 Click OK.

The fonts are exported to the specified file.

Stop Download or Export during Processing

To stop the font downloading or exporting file process:

1 Click Stop Download.

2 Confirm that you want to stop the process by clicking Yes in the confirmation 
dialog.

The download or export process is cancelled. 
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Installing and Using the Xerox
 TCP/IP Port Monitor

The Xerox TCP/IP Port Monitor is used with Bi-Directional CentreWare printer 
drivers (Windows 95/98/Me/NT/2000/XP) and for printing in Windows using LPR or 
Port 9100. 

Bi-Directional communication (Bi-Di) allows a printer driver to communicate with 
the printer through your network. When the printer driver properties are accessed, the 
printer driver can acquire information from the printer, including its current 
operational status and configuration. 

When printing with LPR or Port 9100 printing protocols, the Port Monitor enables the 
Windows print spooler to send documents to CentreWare Document Centres.

What�s in this chapter:
! Installing the TCP/IP Port Monitor  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-2

! Upgrading the TCP/IP Port Monitor  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-3

! Uninstalling the TCP/IP Port Monitor . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-4

! Accessing the Xerox Add TCP/IP Printer Port Wizard . . . . . . . . . . . . . . . 5-5

! Adding and Configuring a TCP/IP Port . . . . . . . . . . . . . . . . . . . . . . . . . . 5-6

! Deleting a TCP/IP Port. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-13
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Installing the TCP/IP Port Monitor
The Xerox Printer Installer automatically installs the TCP/IP Port Monitor to your 
workstation during the Printer Driver installation when a peer-to-peer connection is 
chosen for your printer. The Port Monitor may also be installed, manually, on your 
workstation or a Windows NT/2000 print server. If you install the Port Monitor on a 
Windows NT/2000 terminal server, both NT and 2000 clients will be able to access 
the configuration and status information gathered by the port. 

To install the Port Monitor to a server or workstation:

1 Insert the CentreWare Print and Fax Drivers CD into the appropriate drive. The 
Autoplay program starts. For an 95/98/Me/NT/2000/XP workstation or NT/2000 
print server continue with the following steps.

2 Click Utilities.

3 Click the Install Port Monitor wizard for your operating environment:

! 95/98/Me

! NT/2000/XP

4 Select Install/Upgrade Port Monitor. Click OK.

5 If you receive a prompt to stop the Windows print spooler, click OK. The 
Windows print spooler must be stopped before the appropriate extension file can 
be removed for the installation. The spooler is restarted when the installation is 
completed. 

6 The files are copied to the server or workstation. On the success dialog, click 
OK.

The Port Monitor is installed and available for use when adding/configuring a 
TCP/IP port.

NOTE: To install the Port Monitor on an NT terminal server you must use the Add/
Remove Programs feature on the Start menu: Settings > Control Panel dialog to 
access the Port Monitor Setup.exe. When the Install/Upgrade Port Monitor 
dialog opens, continue with step 4.
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Upgrading the TCP/IP Port Monitor
To upgrade the Port Monitor:

1 Insert the CentreWare Print and Fax Drivers CD into the appropriate drive. The 
Autoplay program starts. For an 95/98/Me/NT/2000/XP workstation or an NT/
2000 print server, continue with the following steps. 

2 Click Utilities.

3 Click the Install Port Monitor wizard for your operating environment:

! 95/98/Me

! NT/2000/XP

4  Select Install/Upgrade Port Monitor. Click OK.

5 If you receive a prompt to stop the Windows print spooler, click OK. The 
Windows print spooler must be stopped before the appropriate extension file can 
be removed for the upgrade. The spooler is restarted when the upgrade is 
completed. 

6 The files are copied to the server or workstation. On the success dialog, click 
OK.

7 The Port Monitor is upgraded.

NOTE: To upgrade the Port Monitor on an NT terminal server, you must use the 
Add/Remove Programs feature on the Start menu: Settings > Control Panel 
dialog to access the Port Monitor Setup.exe. When the Install/Upgrade Port 
Monitor dialog opens, continue with step 4.
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Uninstalling the TCP/IP Port Monitor 
To uninstall the Port Monitor:

1 Disconnect all printers from TCP/IP ports. If any printers are connected, a 
warning appears, indicating that the uninstall process cannot continue.

2 Insert the CentreWare Print and Fax Drivers CD into the appropriate drive. The 
Autoplay program starts. Click Utilities.

3 Click the Install Port Monitor wizard for your operating environment:

! 95/98/Me

! NT/2000/XP

4 Select Remove Port Monitor. Click OK.

5 The files are removed from the server or workstation. At the success prompt, 
click OK.

The Port Monitor files and registry entries are removed. 

NOTE: To uninstall the Port Monitor on an NT terminal server you must use the 
Add/Remove Programs feature on the Start menu: Settings > Control Panel 
dialog, rather than the CentreWare Port Monitor CD wizard. 
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Accessing the Xerox Add TCP/IP Printer 
Port Wizard
The Xerox Add TCP/IP Printer Port Wizard steps you through the process of adding a 
port for a printer on your network. The wizard locates a printer and then automatically 
configures a TCP/IP port for it. You access the wizard from the printer driver when 
you select to add a port. 

Additionally, if the wizard cannot locate a printer and automatically configure the port 
for it, you can specify parameters for defining the port and then configure it manually.

Accessing the Wizard
To access the wizard:

1 Select Start > Settings > Printers.

2 Right-click on the desired printer and select Properties.

3 Select:

! the Details Tab (95/98/Me).

! the Ports Tab (NT/2000/XP).

4 Click Add Port. The Add Port dialog opens.

5 For 95/98/Me, select Other, then select Xerox TCP/IP Port and click OK. The 
Xerox TCP/IP Port Wizard opens.

�Or�

For NT/2000/XP, select Xerox TCP/IP Port and click New Port. The Xerox 
Add TCP/IP Printer Port Wizard opens.
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Adding and Configuring a TCP/IP Port
To add and configure a port using the wizard:

1 On the Xerox TCP/IP Port dialog, click Next to continue. The Add Xerox TCP/
IP Port dialog opens.

2 Type a name for the printer port. This name can be up to 50 characters in length 
and must be unique. The port name cannot match any other port name that is 
configured on your network.

3 Perform one of the following steps:

! Type the desired printer�s DNS name or IP address. 

! Click Auto Printer Discovery if you do not know the printer�s DNS name 
or IP address. 

The Auto Printer Discovery searches your local network for printers. 

If no printers are listed click Refresh. A local search on the network is initiated. 
When finished, a dialog displays a list showing the results. If no printers are 
discovered, click Subnets to extend the search. See Subnets Dialog on page 5-12.

Figure 5-1:  Add Xerox TCP/IP Port dialog
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4 Select a network printer for this port. Click OK.

5 On the Add Xerox TCP/IP Port dialog, click Next. The port is automatically 
configured to the default port settings. The settings are displayed on the 
Completing Dialog.

6 On the Completing dialog, click Finish if the information is correct. If the 
settings are not correct, click Back; an Additional Information dialog appears.

Figure 5-2:  Printer Discovery Dialog

Figure 5-3:  Completing the Bi-Directional Port Setup Dialog
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Additional Information Dialog
If you know that the printer�s IP address or DNS name is correct, but the printer 
cannot be located on your network, an additional information dialog appears. This 
dialog is used to input additional information about a printer, so that the Add TCP/IP 
Printer Port Wizard can configure the port. 

To add and configure a port for a printer that cannot be located:
Perform one of the following procedures:

! If you know the printer type, click Standard and select a printer type from 
the drop-down list.

Click Next. The port is configured. The settings are displayed on the 
completion dialog.

If all the settings are correct, click Finish. 

-OR-

! If the printer type is not listed in the Standard drop-down list, click Custom. 
The Xerox TCP/IP Port - Configuration dialog appears, on which you can 
manually configure the port settings.

Figure 5-4:  Additional Information dialog
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Click OK to apply the settings.

Figure 5-5:  Xerox TCP/IP Port � Configuration Dialog
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Manually Configuring a TCP/IP Port 
You can use this procedure to configure manually the current settings for a port.

To configure a TCP/IP port:

1 Select Start > Settings > Printers.

2 Right-click on the desired printer and choose Properties.

3 Select 

! the Details Tab (95/98/Me).

! the Ports Tab (NT/2000/XP).

4 Select the Xerox TCP/IP Port that you want to configure or edit.

5 Click 

! Port Settings (95/98/Me).

! Configure Port (NT/2000/XP). 

The Xerox TCP/IP Port - Configuration dialog appears.

Figure 5-6:  Xerox TCP/IP Port Configuration Dialog
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6 Several settings are available for modification, including:

! Printer Name or IP Address

The DNS printer name or IP address of the connected printer.

! Protocol

Supported protocol, either LPR or RAW (port 9100).

! Raw Settings

TCP port number, usually port 9100 which is the setting default.

! LPR Settings

The queue name is used to specify the LPR queue name. Most Xerox 
Document Centre products use Ip for the name of the remote print server or 
queue.

! Bi-directional Settings:

Bi-directional communication enabled�enables or disables bi-directional 
status and configuration information through the port.

Update configuration�specifies how often the network is polled for 
changes to the connected printer�s configuration. The minimum setting is 5 
seconds and the maximum is 600 seconds or 10 minutes. 

Update status�specifies how often the printer is polled for changes in its 
status. The minimum setting is 5 seconds and the maximum is 600 seconds 
or 10 minutes. 

SNMP Community Name�specifies the name of the SNMP community in 
which the printer resides. The default is public. 

7 When finished, click OK to apply the settings.
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Subnets Dialog
The Subnets dialog enables you to extend the search for printers on your network. 

To search the subnets:

1 Enter Subnet Mask or Subnet Addresses to refine the search. Click Add to add 
the Subnet information to the Subnet Address List. 

2 When finished, click OK to perform the subnet search. The Auto Printer 
Discovery returns IP address(es) for printers found in the subnet search.

3 On the Printer Discovery dialog, Click Refresh to update the dialog.

See Printer Discovery Dialog on page 5-7.

Figure 5-7:  Subnets Dialog
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Deleting a TCP/IP Port
To delete a TCP/IP port:

1 Select Start > Settings > Printers.

2 Right-click on the desired printer and select Properties.

3 Select

! the Details Tab (95/98/Me).

! the Ports Tab (NT/2000/XP).

4 Select the TCP/IP port to delete.

5 Click Delete Port.

6 On the confirm dialog, click Yes to delete the selected port.

The port is removed.
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Installing and Using the
TIFF Submission Tool

The TIFF Submission Tool enables you to submit TIFF (Tagged Image File Format) 
and PDF (Portable Document Format) files directly to a Document Centre for 
printing. 

The primary advantage of this application is that it does not add additional PostScript 
information to the submitted file (often referred to as a PostScript wrapper). Instead, 
the TIFF or PDF files are submitted as print ready files. This enables the Document 
Centre RIP (Raster Image Processor) to process TIFF and PDF files very quickly.

What�s in this chapter:
! Workstation Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-2

! Supported Document Centres . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-2

! Installing the TIFF Submission Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-3

! Uninstalling the TIFF Submission Tool  . . . . . . . . . . . . . . . . . . . . . . . . . . 6-4

! Features and Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-5

! Using the TIFF Submission Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-6
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Workstation Requirements
The TIFF Submission Tool can be used on workstations that meet the following basic 
requirements:

! Windows 95, 98

! Windows NT 4.0

! Windows 2000

! Windows XP

! 4 MB of hard drive space

Supported Document Centres
The following Document Centre models only support TIFF printing via the TIFF 
Submission Tool:

! DC 490/480/470/460

! DC 555/545/535

NOTE: Your Document Centre must have a TIFF interpreter in order to use this 
tool.

NOTE: Only the latest versions that are compatible with CentreWare 5.30 and 
5.40 provide the required TIFF Interpreter. Check your Document Centre 
configuration to confirm this requirement.
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Installing the TIFF Submission Tool
Use the following procedure to install the TIFF Submission Tool software on a 
Windows workstation.

To install the TIFF Submission Tool:

1 Insert the CentreWare Print and Fax Drivers CD into the appropriate drive. The 
Autoplay program starts.

2 Click Utilities.

3 Click Install TIFF Submission Tool.

4 Click Next on the opening dialog of the installation wizard.

5 Read the Software License agreement and click Yes.

6 Enter your user and company information. Click Next.

7 Click Finish. The CentreWare TIFF Submission Tool is ready for use.
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Uninstalling the TIFF Submission Tool
Use the following procedure to uninstall the TIFF Submission Tool software on a 
Windows workstation.

To uninstall the TIFF Submission Tool:

1 Double-click My Computer > Control Panel > Add/Remove Programs.

2 Select Xerox CentreWare TIFF Submission Tool from the list of software in the 
Add/Remove Programs dialog.

3 Click 

! Add/Remove (Windows 9x and NT).

! Change/Remove (Windows 2000 and XP).

4 Click Yes on the Confirm File Deletion dialog.

The uninstall process runs to completion.

5 Click OK when the uninstall program is successfully completed.
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Features and Options
The TIFF Submission Tool allows you to send single or multiple TIFF or PDF files to 
a Document Centre.

TIFF and PDF file submissions allow you to:

! Enable the Accounting feature

! Select paper and output options for your document.

! Select printing performance options

Figure 6-1:  TIFF Setup Tab
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Using the TIFF Submission Tool
Starting the TIFF Submission Tool
To start the application:

Click Start > Programs > Xerox CentreWare > CentreWare TIFF 
Submission Tool.

Printing a TIFF or PDF File
To submit TIFF or PDF files for printing:

1 Select a compatible printer from the Select Printer list.

2 Indicate the number of copies to be printed.

3 Locate the TIFF or PDF files to be printed.

4 Select each file name, then click ADD (or double-click the file name) to place the 
file name in the Files to Submit box.

5 Enter Personal Accounting codes (if Accounting is enabled and Accounting 
codes are not saved between sessions).

6 Click Print. The TIFF or PDF file prints at the Document Centre.

NOTE: Only the default settings are available for printing PDF files. Any 
changes that are made to the default settings result in a Post Script error when 
printing PDF files.
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Paper/Output Options
To use the Paper/Output Options:

1 Choose the paper size.

2 Select the 2-Sided Printing (1 or 2-Sided) and Image Orientation (Portrait, 
Landscape) options. (TIFF printing only)

3 Select other optional features (Banner Sheet, Finishing, Job Type, Hole Punch, 
and Output Destination) as needed. 

Figure 6-2:  Paper/Output Tab
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Accounting Options
To use Accounting Options:

1 On the User Preference Tab select Use Network Accounting to activate the 
accounting options. The icon appears in full color, indicating Accounting is 
activated.

2 Check Save Accounting Codes. (Optional) Selecting this option saves 
accounting codes between sessions.

3 Check Conceal User ID and Conceal Account ID. (Optional) Selecting these 
options will cause asterisks to display in place of alphanumeric characters within 
the Accounting text boxes on the TIFF/PDF Setup tab.

Figure 6-3:  User Preference Tab
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Performance Options
To configure the TIFF Submission Tool for printing:
Select the User Preference Tab and check one of the following options to activate it. 
See Figure 6-3 User Preference Tab.

1 Use System Print Spooler. This option configures the TIFF Submission Tool to 
send print jobs to the printer using the Print Spooler on your computer. This is the 
default setting for the TIFF Submission Tool.

2 Direct Printing. This option configures the TIFF Submission Tool for TCP/IP 
based printing via LPR or Port 9100. Direct Printing is typically much faster than 
printing using the Print Spooler. However, this option does not offer any form of 
error checking. If you experience any problems with this option, you should 
reconfigure the TIFF Submission Tool to use the System Print Spooler. 

NOTE: When Direct Printing is active, a Configure Printers button 
appears on the TIFF/PDF Setup tab. You can use the Configure Printers 
button to select and configure a printer for LPR or Port 9100 printing.
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 Problem Solving

Application, device, and network errors can occur in a variety of printing situations. 
In many cases, simply restarting the application, the workstation, or the printer will 
resolve the problem. This chapter includes some of the common problems and 
Frequently Asked Questions that pertain to CentreWare Print and Fax Drivers and 
printing to the Document Centre.

What�s in this chapter:
! Troubleshooting a Problem . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7-2

! Common Issues . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7-3

! Frequently Asked Questions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7-9
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Troubleshooting a Problem
When a problem persists, document the error messages and gather information to 
define the problem. The following problem solving procedures are recommended:

! Accurately define the problem. When, where, and how does the problem occur?

! Reproduce the problem. Can the problem be reproduced consistently or is it an 
intermittent problem?

! Ask other users if they have encountered the problem, and keep a log to track 
problem occurrences. 

! Examine the data for trends and the common attributes that may be related to the 
problem. For example, does the problem occur only with a specific printer or on 
a specific workstation/network configuration?

! Review the product documentation, including the README files and the Help 
Centre Problem Solving topics, to see if any similar problems are documented. 

If a cause and solution to the problem cannot be identified, call the Xerox Welcome 
Center to report the error information. Provide the support representative with the 
documentation that you have gathered to define the problem.
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Common Issues
This section discusses some common application and printer driver functionality 
issues.

Adobe Acrobat Printing
All versions of Adobe Acrobat have exhibited various forms of distorted output when 
printing from a PCL driver. Stray lines, random character spacing, and data loss have 
been observed on various PDF documents. The CentreWare PostScript driver is 
recommended for printing Acrobat PDF files.

AdobePS 4.3.1 Compatibility Issues 
Some of the features provided by the core Adobe print driver (which is used by the 
Document Centre PostScript driver for Windows 95/98/Me) are not supported in 
certain applications. These applications may simply ignore the feature and not 
function at all, or a printing error may result in some rare cases. 

The following table includes most of the known application incompatibility issues for 
the Windows 95/98/Me PostScript driver:

Application Printer Driver Feature
Acrobat 3.02, 4.0 Rotated Landscape, Mirror Image, Negative Image

Corel Draw! 8.0 Scaling, Rotated Landscape, Watermark, Euro

Framemaker 5.56 Rotated Landscape

Freehand 7.0, 8.0 Multiple Up (N-up), Scaling, Rotated Landscape, 
Watermark, Mirror Image

Illustrator 8.0 Watermark, Euro

PageMaker 6.5 N-up, Scaling, Rotated Landscape, Watermark, 
Mirror Image, Negative Image, Euro

Photoshop 4.0, 5.0, 5.5 Watermark, Euro

QuarkXPress 3.32, 4.0 N-Up, Rotated Landscape, Mirror Image, 
Watermark, Euro

WordPerfect 7.0 Rotated Landscape

Table 7-1:  Application and CentreWare Printer Driver Feature Issues
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Booklet and Multiple-Up (N-Up) Printing
Some applications do not support booklet or N-up printing.  

! Microsoft Word mail merge documents cannot be printed as booklets or N-up.

! Occasionally, data loss can occur when printing a booklet from Adobe Acrobat in 
Windows NT. If this occurs, turning off the Enable PostScript Passthru option 
in the printer driver may resolve the problem.

! With Windows 95/98/Me PCL drivers, you may need to reset the Booklet or N-
Up settings before you save your documents. Some applications, such as 
Microsoft Word 97, will save the scaling factor with the document. When the 
document is reopened later, the text and graphics may print in a reduced format 
unless you reset the N-Pages Up option on the print driver Layout/Watermark tab 
to 1-Up prior to printing. It is generally best to reset this option to 1-Up before 
you save and close your documents.

! With the Windows 95/98/Me PCL5e printer driver, N-up and booklet printing 
features do not work properly with Corel Draw version 8.

! With the Windows 95/98/Me PCL5e printer driver, use PCL Raster mode to print 
large N-Up/Booklet documents that do not print properly in Vector mode.

Custom Paper Sizes in Windows NT
The Custom Sizes button may be inactive on Windows NT workstations if the print 
driver is opened from an application. When this situation occurs, you must open the 
print driver from the Windows NT Printers Folder (right-click and select Document 
Defaults) to change the Custom Paper Sizes before you open the application.
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Euro Symbol
The Xerox Euro font family was created to support the imaging of the Euro currency 
symbol with fonts that do not yet support this character. The Xerox Euro font family 
consists of the Euro symbol in various styles and weights designed to work in 
conjunction with most popular font styles. Many styles include a symbol at numeric 
width, which conforms to the standard design rules of the Euro symbol, as well as a 
designer version of the character, created to more closely resemble the original font. 
To use the symbol, set the font selection to Xerox Euro and type the keystroke that 
corresponds to the type style you are using. 

! Xerox Euro Fonts are provided on the CentreWare CD within the \drivers\fonts 
folder.

! Additional information and font installation instructions are available via the 
internet on the Xerox website at www.Xerox.com. Windows 95/98/Me users 
should go to the Microsoft web site to download a system update for the Euro 
symbol. 

! If the fonts on your printer are not updated to include the Euro, a box will be 
printed instead of the Euro symbol. A workaround for this problem is to send 
Euro fonts to the printer as bitmapped images.

! For PCL drivers, select the Always Send to Printer option in the CentreWare 
PCL driver (Image Options tab) when printing the Euro symbol. If problems 
persist when printing the Euro symbol, select the Send as Graphics option.

PDF Printing
! When printing a PDF, sending a large file may result in the printing of print limit 

check error sheets or only a banner sheet. If this occurs, print the PDF file using 
the PostScript printer driver or try printing the PDF file using LPR. 

! Windows 95/98/Me PCL5e printer drivers have occasional problems with some 
PDF files, resulting in blank characters and incorrect fonts within the printed 
documents.

NOTE:  Free product updates for Windows 95/98/Me/NT and Windows 2000, 
enable users to input and display the Euro symbol in applications that are Euro 
symbol-enabled.
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Microsoft Applications

Excel
! To change the job type options for any individual document, you must set the job 

type from within Microsoft Excel (Page Setup dialog). Job type changes for an 
individual document will not take effect if you invoke the CentreWare printer 
driver from the Printers folder.

! Excel will generate multiple print jobs instead of multiple copies of a single 
document. This behavior can result in performance degradation, as well as 
inoperability of features, such as Sample Set, that depend on multiple set 
printing. There is no known workaround for this problem.

! Excel may have occasional problems with documents that contain a mix of 
portrait and landscape pages.  Selecting a different print driver, then reselecting 
the original print driver may help to resolve this problem.

PowerPoint
The Microsoft PowerPoint feature that optimizes black and white printing will 
produce undesired results when Raster output is selected as the Graphics Mode in the 
CentreWare printer driver. Do not choose the black and white option in PowerPoint if 
Raster output is required.

Word 6.0
! If you access the print drivers via Microsoft Word Version 6.0, any changes made 

to the print driver settings will be saved as the new default settings. This will 
impact all applications that use the same printer driver.

! Custom paper sizes will not work with Microsoft Word Version 6.0.  This version 
of Word will automatically change any custom paper size defined in the 
CentreWare print driver to the nearest standard paper size.

! Word 6.0 may ignore some print driver setting changes when the printer driver is 
opened from Word and a file is printed immediately after the changes are made. 
If this occurs, it may be necessary to close and reopen the Print dialog within 
Word (File > Print). 
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PCL Printer Driver

Raster Mode 
Use the PCL Raster Mode option to print the following document types with the 
Windows 95/98/Me PCL5e printer driver:

! Web pages with animated images.

! Printing Corel Draw documents. Corel Draw may generate an excessive 
number of Vector commands, which may result in large amounts of 
processing time for each job.

Print Colored Text in Black
This feature may not work with some applications, or you may have to select the 
option from within the application if it is supported. Certain applications, such as 
WordPerfect and MS Publisher, always print text as graphics or may default to the 
graphics mode when memory is low or when the text is very complex. When these 
circumstances occur, the Print Colored Text in Black feature in the CentreWare PCL 
printer drivers will not work.

Watermark Prints in Foreground Instead of Background
With some applications, the CentreWare PCL drivers may appear to print watermarks 
in the foreground even when the background printing option is selected in the driver. 
This is due to the different methods applications used to send data to the printer. 

The only known workaround for this problem is to reduce the density of the 
watermark so that it will not overwrite the text in your document.

Port Monitor installation (upgrade or uninstall) on an 
NT Terminal Server
In order to install, upgrade, or uninstall the Xerox TCP/IP Port Monitor on an NT 
Terminal Server, you must use the Add/Remove Programs feature on the Windows: 
Settings > Control Panel dialog to access the Port Monitor Setup.exe. This limitation 
seems to apply to any application installation on the NT Terminal Server. If you 
attempt to install or upgrade the Port Monitor on an NT Terminal Server by using the 
CentreWare Install/Upgrade Wizard, without first using the Add/Remove Programs 
feature, the installation/upgrade will start but will end with an error message stating 
that the Add Monitor failed.
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Sample Set Not Supported in Framemaker
Some applications generate print data that is intended for page printers rather than 
document printers, like the Document Centre series. When the print data is sent in this 
format, the Document Centre will print the first set of a Sample Set job, but the 
remaining sets of the document will be discarded. There is no known workaround for 
this problem.

Watermarks
The Watermark preview image in the print drivers may not provide an exact replica 
of the printed watermark under all conditions.  This is primarily due to font and/or 
resolution differences between the display monitor and the printer.  Using equivalent 
True Type fonts instead of printer resident fonts will help minimize the differences.

WordPerfect
! With WordPerfect 8.x running in Windows, you cannot staple multiple jobs as 

separate documents. For example, if you print three sets of a 3-page document, 
WordPerfect will deliver all three sets as a single 9-page document.

! Sample Set job types will not work with WordPerfect 8.x for Windows.

! B4, JIS, B4 ISO, B6, and A6 paper sizes do not print with WordPerfect 8.x for 
Windows.  

! The scaling option in WordPerfect versions 7, 8, and 9 will override the Scaling 
option in the CentreWare drivers. Use the scaling option in the Print/Customize 
property sheet to adjust scaling rather than the CentreWare print driver scaling 
option.

! With WordPerfect 6.1, the Playbill font may not print correctly when the Use 
Printer Fonts option is selected because the printer does not support the Playbill 
font.
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Frequently Asked Questions
! How do I obtain printer drivers?

Printer drivers are available on the CentreWare Print and Fax Drivers CD-ROM or 
from the CentreWare website at www.Xerox.com. See Obtaining CentreWare Print 
and Fax Drivers on page 1-4 for more information.

! How do I determine what printer driver is needed?

The following information is necessary to determine the correct printer driver:

! model of the Document Centre, for example, DC 535 

! operating system environment, for example, Windows NT 

! type of printer driver, for example, PostScript or PCL.

! How do I obtain a custom driver for an environment, such as DOS or a 
mainframe platform?

For DOS or other platforms, which are not supported by CentreWare Document 
Centre printer drivers, the PDL (Printer Description Language) Reference Guide is 
available by accessing DC Tips at www.Xerox.com. The PDL Reference Guide 
contains syntax information about the extended features of the Document Centre, 
which can be used to customize printing in unsupported environments.

NOTE: For Windows NT environments, if you are upgrading a PostScript 
printer driver from an existing one, you will additionally need to know the 
version of the printer driver that you are currently using (upgrading from). 
To find out, access the printer driver properties and click the About tab. If 
your current driver is a CentreWare version that is previous to 5.2, contact 
customer support before performing an upgrade.
Frequently Asked Questions 7-9
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